Circuitbenders Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Circuit bent Korg Poly 800, stuck on "Load" problem.  (Read 1146 times)

Voja

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Circuit bent Korg Poly 800, stuck on "Load" problem.
« on: January 26, 2017, 10:01:53 PM »

Hello everyone :)

I have recently got a Korg Poly 800 that has most of the standard mods done to it (Slayer, FM, input and from the internal looks of it the sysex addition as well). Previous owner swears that it has worked perfectly fine until a move to a new studio, after which it stopped working normally and started egsibiting symptoms it still has.

SYMPTOMS:
When powered up, it only shows "Load, no sound is reproduced and it reacts only to the "cancel" button press. When pressed, display shows "Tape" while the button is held. As soon as it's let go, it goes back to "Load".

I have tried loading up the tape wave, display blinks, but so far only "Err" or no response was the result, either way, I suspect something else is the problem, but I will report what I have tried so far in hope that someone can help me out diagnose this little one and get her well again.

I noticed one important thing. Volume outputs sound as slight hum can be heard and affected by the volume. What I noticed is, when powered up, display show for a tiny fraction of a second the 11 P, default reading of the first patch before going to "Load". Guided by this I tried one thing, repeatedly pressing one of the numbers on the keypad and the turning it on an, hooray, the fraction of the second would show it switch to 14 P, for example" before going to "Load".

This leads me to believe that it is behaving as if something is constantly pressing the "Load" button. The button is not mechanically stuck, it works as it should, but since I haven't had this synth with me before I have 2 questions that I hope you can help me with.

1. On your healthy Korg Poly 800, if you power it up and the just keep the "Load" button pressed, do you get similar type of behavior?

2. Is it possible that something got stuck in the button itself causing it to be "pressed" constantly, since the problem occured after a move (physical stress, debris). Or is it maybe shorted out, or the button switch simple failed and is pressed constantly?

Is my train of thought correct, and do you maybe have some additional advice on how I could approach this one?

I have tried searching for this kind of problem, but I can't find any info on anything similar, so I really hope that some of you can point me in the right direction. I also want to point out that I have the service manual, but I was unable to find any info regarding this kind of problem in there either.

Many thanks in advance :)
Logged