Circuitbenders Forum

Please login or register.

Login with username, password and session length
Advanced search  


Author Topic: Alesis HR-16, lcd lights up, sound output buzzing, thatís all it does!  (Read 1333 times)


  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1

Hello, hoping someone will have experienced this problem and can share a solution, I have come to a dead end after trying a variety of things.

Been making notes, iíll paste it in.

Alesis HR-16 symptoms

No buttons do anything, the only life in it is the lcd has lit up with a feint underscore in the first box as the only visible character.

The only sound being output is a buzzing sound, Output 2 louder than Output 1. 

Initially it had the lcd lit up and the red leds on but since worked out thatís from the 2 main ribbons cables the wrong way around. There was a painted white dot on each board indicating presumably which one to connect to? The cables cross left to right to the connectors, not directly above each other. Switched around like said before all the red leds come on.

Lever has snapped on ďSelectĒ slider but can still move with some improvising.

What Iíve done so far after following a post with identical symptoms...

Changed all the capacitors around by the power source input.
Bought a new power supply 9v AC/AC, 1.5A.
Battery is healthy, reading 3.6v.
Tried all the resets Iím aware of from the service manual.

Still not booming - any help and wisdom hugely appreciated!

Thank you,


* A bit more has come to life after holding PATT and VOICE buttons switching on - the lcd now says SELECT PATT 00
Display is very feint, gets more defined if I hold it at an angle.
No buttons are responding regardless of this progress.

Switching on has start up screen ALESIS HR-16. VERSION 1.06

Sorry for all the updates - I swapped the leads back around, there was more white painted dots indicating what goes where. The red led by PATT is on, the buttons on the right can be selected with a hard press, MIDI / UTIL selecting ok  and the SELECT slide scrolling through the functions.

Still no sounds though, just the awful buzzing. Pressing on the largest eprom reduced the noise.

Thank you!
« Last Edit: July 09, 2019, 02:29:39 AM by MarkJ1200 »