Circuitbenders Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: HR 16 Keyboard Matrix  (Read 1431 times)

hoffy

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 47
HR 16 Keyboard Matrix
« on: March 23, 2016, 02:06:25 PM »

Hi Guys,

Having a look at the service manual for the HR16, there's a keyboard matrix which controls all the buttons on the unit.

One of the rows- the one which includes the play, tune, and voice buttons- does not work at all!

This obviously sucks because I want to play with my bent HR 16!

Gotta say... first post in a while. I still check this forum from time to time. Keep breaking and bending kids!

Hoffy.
Logged

Circuitbenders

  • crustypaul
  • Admin
  • This person is dangerously insane.
  • *****
  • Karma: 1102
  • Offline Offline
  • Posts: 2446
    • Circuitbenders.co.uk
Re: HR 16 Keyboard Matrix
« Reply #1 on: March 24, 2016, 08:37:36 PM »

Well your first thing to check would be to use a meter to make sure that the row that connects to all those buttons is actually connected to pin 16 of U14. You sometimes see hairline cracks in the tracks on the button board, or more often around the solder joints for the ribbon connectors. In this case pin 2 on J13.

Next step would be looking at replacing U14 i guess.
Logged
i am not paid to listen to this drivel, you are a terminal fool

hoffy

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 47
Re: HR 16 Keyboard Matrix
« Reply #2 on: March 27, 2016, 12:05:00 PM »

Thanks very much mate!

It turns out, the data cable between the keypad board and J13 was busted; in fact, the unit actually has three data cables in it, two of which did not work in transmitting data between the mainboard and the keypad board.

 In the end, I used an data cabe from a pc to get it working. Very strange.

Unfortunately, in the process, the Data Slider has stopped working, which means the unit won't receive MIDI. Very frustrating... it might be time to buy a new one and try another build :/

Thanks again!
Logged