Circuitbenders Forum

Please login or register.

Login with username, password and session length
Advanced search  


Author Topic: Casio SA-35 - power crash knob / DC adaptor removal gone wrong  (Read 412 times)


  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1

Hello everybody ^-^
Couldn't find any topic with the same issue, hope I'm not repeating!
I have a Casio SA-35, its my first bending project, I was following the usual SAs charts for bending and something went wrong. I removed the DC adapter and soldered a 1k pot for power crash. (Terminals 2 and 3 to the respective "holes" in DC adaptor place in the circuit)
I turned on the keyboard and I could hear sound, but the notes would last just seconds, sound was getting cut. So I guessed it was either my beautiful soldering job or the resistance of the pot was wrong, since I knew 500ohm was indicated (but thought 1000k would work anyway, since I saw it also in another schema).
So I de-soldered the pot - turned keyboard on, no sound at all.
So I put the DC adaptor back, still no sound coming.
But I was fiddling around because I couldn't believe I fried my toy in the first try and turns out is not dead, when I connect the + of the batteries to the metal thingy inside the DC adaptor the keyboard works - but also sparks and gets hot so I guess this is no good :P
Already tried new batteries so that's not the issue.

Anybody has an idea what I did wrong? Or how can I fix it?

Any tips are appreciated!
Thank you so much :)