Circuitbenders Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3
  Subject Started by Replies Views Last post
Kawai R50 no sound from Right output digix 1 159 Last post January 06, 2021, 03:29:21 PM
by Circuitbenders
Guitar Amplifier noise when a DC adaptor used. bzomb 0 198 Last post October 26, 2020, 12:06:37 PM
by bzomb
Telephone Microphone Circuit Bent POTENTIOMETER HUMMING bzomb 0 146 Last post October 26, 2020, 12:05:02 PM
by bzomb
VSS30 Sample Distorting Issue - Help Appreciated! simon_whitehead 0 212 Last post October 14, 2020, 12:24:16 PM
by simon_whitehead
Yamaha PSS-270 question (dead or fixable) Asdfguy86 0 321 Last post June 08, 2020, 05:18:29 AM
by Asdfguy86
What do you do to replace broken solder pads? WeirdoSheep 1 395 Last post May 13, 2020, 01:39:28 PM
by Circuitbenders
VSS-30 advice insch 4 2207 Last post February 08, 2020, 01:08:37 PM
by Vanx
Yamaha vss-30 HELP NEEDED electroclone 9 6649 Last post January 27, 2020, 08:55:10 AM
by Vanx
korg poly 800 - no power mmoore5553 2 1072 Last post June 14, 2019, 05:30:24 PM
by mikekvan
Korg poly 61 voice retuning Circuitbenders 13 13602 Last post June 14, 2019, 05:25:52 PM
by mikekvan
How hard would it be to fix this? [Kawai X30] Asdfguy86 0 785 Last post January 08, 2019, 01:59:01 AM
by Asdfguy86
Will this LTC1799 PCB module work? Asdfguy86 2 1423 Last post May 28, 2018, 02:54:01 AM
by Asdfguy86
Roland S-760: A question about replacing crystals Ciderfeks 6 1839 Last post September 22, 2017, 05:56:01 PM
by Ciderfeks
Casio SK1 Won't power on . . . Luckyhat66 0 1455 Last post December 17, 2016, 01:45:42 AM
by Luckyhat66
Casiotone mt-86 Droeee 0 1223 Last post October 03, 2016, 05:02:48 PM
by Droeee
Casio PT-10 is screwed iwillbeacircuitbender 0 1295 Last post September 20, 2016, 09:02:38 PM
by iwillbeacircuitbender
Casio SK5 wih messed powerplug Somu 6 2078 Last post April 03, 2016, 11:32:02 PM
by Somu
Batteries over heating. TinyObjekts 4 2772 Last post November 30, 2014, 09:47:30 PM
by TinyObjekts
poly 800 doesn't power-on after "native" green cable unplugged frengo 1 2738 Last post June 09, 2014, 12:50:58 PM
by Circuitbenders
korg poly 800 power prblem « 1 2 » natere2ster 18 15148 Last post November 20, 2013, 11:42:19 PM
by YashN
Pages: [1] 2 3

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll